GHSA-54xq-cgqr-rpm3
- Sévérité
- Élevée
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA KEV
- Absente du catalogue KEV en cache
- EPSS
- Aucun score EPSS en cache
Versions touchées et corrigées
- Introduite en 0 · corrigée en 0.32.6
La dernière version publiée n'est pas dans une plage touchée, ou OSV n'indique aucun correctif.
Le texte simplifié n'apparaît que s'il est déjà en cache. Cette page ne le génère pas.
sharp vulnerability in libwebp dependency CVE-2023-4863
## Overview sharp uses libwebp to decode WebP images and versions prior to the latest 0.32.6 are vulnerable to the high severity https://github.com/advisories/GHSA-j7hp-h8jx-5ppr. ## Who does this affect? Almost anyone processing untrusted input with versions of sharp prior to 0.32.6. ## How to resolve this? ### Using prebuilt binaries provided by sharp? Most people rely on the prebuilt binaries provided by sharp. Please upgrade sharp to the latest 0.32.6, which provides libwebp 1.3.2. ### Using a globally-installed libvips? Please ensure you are using the latest libwebp 1.3.2. ## Possible workaround Add the following to your code to prevent sharp from decoding WebP images. ```js…
Alerte sur OSV.dev · publiée le 2023-11-16 · modifiée le 2023-11-16