GHSA-54xq-cgqr-rpm3
- Gravità
- Alta
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA KEV
- Non presente nel catalogo KEV in cache
- EPSS
- Nessun punteggio EPSS in cache
Versioni interessate e corrette
- Introdotta in 0 · corretta in 0.32.6
L'ultima versione pubblicata non è in un intervallo interessato, oppure OSV non indica correzioni.
Il testo semplificato appare solo se già in cache. Questa pagina non lo genera.
sharp vulnerability in libwebp dependency CVE-2023-4863
## Overview sharp uses libwebp to decode WebP images and versions prior to the latest 0.32.6 are vulnerable to the high severity https://github.com/advisories/GHSA-j7hp-h8jx-5ppr. ## Who does this affect? Almost anyone processing untrusted input with versions of sharp prior to 0.32.6. ## How to resolve this? ### Using prebuilt binaries provided by sharp? Most people rely on the prebuilt binaries provided by sharp. Please upgrade sharp to the latest 0.32.6, which provides libwebp 1.3.2. ### Using a globally-installed libvips? Please ensure you are using the latest libwebp 1.3.2. ## Possible workaround Add the following to your code to prevent sharp from decoding WebP images. ```js…
Avviso su OSV.dev · pubblicato il 2023-11-16 · modificato il 2023-11-16