GHSA-54xq-cgqr-rpm3
- Severity
- High
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA KEV
- Not in the cached KEV catalog
- EPSS
- No cached EPSS score
Affected and fixed versions
- Introduced 0 · fixed in 0.32.6
The latest published version is not inside an affected range, or OSV lists no fix for it.
Plain-language text is shown only when it is already cached. This page does not generate it.
sharp vulnerability in libwebp dependency CVE-2023-4863
## Overview sharp uses libwebp to decode WebP images and versions prior to the latest 0.32.6 are vulnerable to the high severity https://github.com/advisories/GHSA-j7hp-h8jx-5ppr. ## Who does this affect? Almost anyone processing untrusted input with versions of sharp prior to 0.32.6. ## How to resolve this? ### Using prebuilt binaries provided by sharp? Most people rely on the prebuilt binaries provided by sharp. Please upgrade sharp to the latest 0.32.6, which provides libwebp 1.3.2. ### Using a globally-installed libvips? Please ensure you are using the latest libwebp 1.3.2. ## Possible workaround Add the following to your code to prevent sharp from decoding WebP images. ```js…
Advisory on OSV.dev · published 2023-11-16 · modified 2023-11-16